Here we list the technical requirements for installing and running Joomla.

The tables below are based on the latest release version of

  • J4Joomla 4 which is currently version 4.4.2
  • J5Joomla 5 which is currently version 5.0.2

For security reasons and features you are always advised to use the latest stable version of Joomla.

There are a number of web hosts who specialise in hosting Joomla web sites - in choosing your host ensure that they meet the following technical requirements for Joomla.

A good host will allow users to choose from a selection of PHP versions.

usingjoomla.com recommends SiteGround

J4Joomla 4 Requirements
Software Recommended
Version *
Minimum
Version *
PHP
8.2
(or newer)

7.2.5
Supported
Database
Recommended
Version *
Minimum
Version *
MySQL
8.0
(or newer)

5.6

SQL Server

(Microsoft Servers Database)

Not supported
by Joomla 4
Not supported
by Joomla 4

PostgreSQL

(Linux Servers)

11.0
(or newer)
11.0
J4Joomla 4 Requirements
Supported
Web Servers
Recommended
Version *
Minimum
Version *
Apache
2.4
(or newer)

2.4
Nginx
1.18
(or newer)

1.10

Microsoft IIS


10
(or newer)

8
Note-pinNotes

End of regular bugfix Support for 4.x is the 15th October 2024

End of security fix only Support for 4.x is the 14th October 2025

* Recommended Versions
* Minimum Versions


The recommended version listed is the version which is known to work

The minimum version is the version which is guaranteed to work

Older versions than the minimum version may still work but are NOT supported

Article Navigation Assistant

J4Go to top of Joomla 4 Requirements (this column)

J5Go to top of Joomla 5 Requirements
Back To Top UJGo to top of page

J5Joomla 5 Requirements
Software Recommended
Version *
Minimum
Version *
PHP
8.2
(or newer)

8.1.0
Supported
Database
Recommended
Version *
Minimum
Version *
MySQL
8.1
(or newer)

8.0.13

SQL Server

(Microsoft Servers Database)

Not supported
by Joomla 5
Not supported
by Joomla 5

PostgreSQL

(Linux Servers)

16.0
(or newer)
12.0
MariaDB
11.1.0
(or newer)

10.4.0
J5Joomla 5 Requirements
Supported
Web Servers
Recommended
Version *
Minimum
Version *
Apache
2.4
(or newer)

2.4
Nginx
1.25
(or newer)

1.21

Microsoft IIS

10
(or newer)
10
Note-pinNotes

* Recommended Versions
* Minimum Versions


The recommended version listed is the version which is known to work

The minimum version is the version which is guaranteed to work

Older versions than the minimum version may still work but are NOT supported

Article Navigation Assistant

J4Go to top of Joomla 4 Requirements

J5Go to top of Joomla 5 Requirements (this column)
Back To Top UJGo to top of page

Hosting

Joomla Websites Showcase

SimSurprise

For articles, tips, hints, tools, videos and much more relating to Mobile Phones, and the mobile phone industry, visit. . .

simsurprise.co.uk


TimAustin.co.uk

For more about the travels of the UsingJoomla.com Website developer, visit . . .

TimAustin.co.uk


header copy
For images, hints and tips on New Zealand postage stamps and philately
Philately co nz


Downtown SanFrancis.co

DownTownSanFrancisco